Symptom
This happens when configuring Payment Information portlet for the first time.
This happens when you migrate from Direct deposit to Payment Information V3
Many fields like Account Owner, Routing Number, Account Number, IBAN, etc does not get displayed when creating Payment Information of any employee.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental
Environment
Employee Central - Payment Information
Reproducing the Issue
Navigate to any employee's Personal Information --> Payment Information --> Edit.
Cause
This is caused by the UI Rules not being initialized as required, please see the following section of the handbook:
Please be aware that you activate the predelivered rules by reselecting the values in the IF section of each rule.
Resolution
- Navigate to Admin Center --> Manage Configuration UI --> Payment Information --> Manage UI Rules:
- Select the business rule "Bank Transfer":
- Select the Payment Method that should be configured. Please reselect it even if it's already selected. Then click on Save --> Close --> Save.
- Carrey out the above steps for all UI Rules
- This will resolve the issue and all the expected fields will be available when creating Payment Information for an employee.
Keywords
Payment, Method, Field, Display, Showing, Configuration, UI, Rules, Refresh, Reselect, Payment Information Migration, Direct deposit, fields missing, amount, percent, payment info , KBA , LOD-SF-EC-PAY , Payment Information (Bank Information) , Problem