SAP Knowledge Base Article - Public

2249563 - Error: java.io.IOException: No space left on device

Symptom

Error received after run an import/export data job:

java.io.IOException: No space left on device

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors HCM Suite

Reproducing the Issue

While trying to do an import/export of the file (say picklist) the system throws the below error:

Status: FAILED

java.io.IOException: No space left on device

Cause

The error is caused because of a lack of disk space in data center.

Resolution

Try again after sometime, as the disk space is cleaned up regularly.

If the issue persists, please create a case with SuccessFactors Cloud Product Support providing the error message received and the operation that you were trying to carry out.

Keywords

IOException No space left on device, export error, Data Import/Export , KBA , LOD-SF-MDF-IMP , Import and Export Issues , LOD-SF-PLT , Platform Foundational Capabilities , Problem

Product

SAP SuccessFactors HCM Suite all versions