Symptom
Customer is running the User Connector - SF connector but the users' timezone and currency is not updating.
Environment
SuccessFactors Learning Management System (LMS) - All Supported Versions
Cause
For Time Zone field this issue happens because the feature sfuser.connector.update.updatePreferences is set to "N" in the Connector Properties.
For Currency field, this is not possible.
Resolution
Updating Currency field for existing users is not possible via Connector, as the users may modify the preference via the UI. This setting will only determine the value for newly created users:
- sfuser.connector.defaultValue.preferenceCurrency=
As a workaround, the Import Data tool can be used to update currency field in bulk.
To update Time Zone field via connector, admins will need to change the value of the feature sfuser.connector.update.updatePreferences from N to Y. To do so you will need to:
- System Administration > Configuration > System Configuration > Connectors
- Do a CTRL + F and search for sfuser.connector.update.updatePreferences
- Set it to Y
- Click on "Apply Changes"
Before loading the user data file, please also make sure to configure the features below with the value that the users will be updated with.
- sfuser.connector.defaultValue.preferenceTimeZone=
Please make sure that these values exist in your LMS or the connector will reject the users records.
NOTE: Same thing applies to User Connector >> user.connector.update.updatePreferences=Y & the Admin Connector >> admin.connector.update.updatePreferences=Y
See Also
3085902 - Fatal error updating User Timezone field not being Updated via connector
Keywords
user connector sf, update preferences, timezone and currency, sfuser.connector.defaultValue.preference, sfuser.connector.defaultValue.preferenceTimeZone, sfuser.connector.defaultValue.preferenceCurrency, sfuser.connector.update.updatePreferences , KBA , LOD-SF-LMS-CON , Connectors , LOD-SF-LMS , Learning Management System , Problem