Symptom
Some of your Onboarding notifications are not getting triggered for some candidates.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SucessFactors Onboarding 1.0 - All Versions
Cause
This issue can have different causes - In this article we will cover the one related to Advanced conditions in Notifications.
Resolution
The initial check is to confirm the configuration of the notifications, see below on what needed to be checked.
Check if E-Mail was Sent in Mail Queue
- Login to SAP SuccessFactors HCM and navigate to Admin Center
- Under Tools, find and select "Manage Onboarding Settings"
- Click the Mail Queue tab
- Use the search function to locate the notification
Check if Notification have an Advanced Conditions
- Login to SAP SuccessFactors HCM and navigate to Admin Center
- Under Tools, find and select "Manage Onboarding Notifications"
- In the left pane, scroll down and find the Notifications under "All Notifications by Processes"
- Search the notification and highlight to show Advanced button; click Advanced
- Verify if there is a field and value required for the notification to work; for example, if the key RemoteHire is set as No in record of candidate it should trigger the notification else, when the value is Yes the notification will not trigger
Check if Candidate Meet the Advanced Conditions
- Login to SAP SuccessFactors HCM and navigate to Onboarding
- Under Onboarding Dashboard, click Reports
- In Reports, click Advanced Reports and press Create button to generate candidate data
- A dialog box will appear and step 1 to enter the report name; click Next button once name is populated and uncheck the Based on Template
- In step 2, please add the following keys: HRDataID, Process, FirstName, LastName, and the key that is set in the Notifications (For example, in the screenshot below we are using RemoteHire as the key in the Notifications Advanced Condition)
- In step 3, filter the report by FirstName and LastName to show specific user; click Next
- Click Finish; no need to save it as template
- Once the report is completed and 100%, kindly download and check if the record of hire matches with the advanced condition set it Notifications; if the condition is not met then it is an expected behavior else, you need to engage with support team to verify if condition was met and notification is not triggered; see below on how to engage with support
Keywords
Notification not received, notification not triggered, advanced, condition, filter, onboarding, obd, 1.0 , KBA , LOD-SF-OBD-EML , Emails and Notifications , LOD-SF-OBD , Onboarding , Problem