SAP Knowledge Base Article - Public

2253897 - Error Message Shown While Creating a new Contact

Symptom

Error message shown while creating a new Contact: For some possible duplicates you do not have sufficient authorizations; these duplicates are shown in the list of duplicate check results ;however you will not be able to see all their details.

Reproducing the Issue

  1. Login to HTML UI with user XYZ (XYZ represents the ID of the user).
  2. Create a new Contact from Quick Create section.
  3. Try to create a new contact by adding detelils like Name, Last Name etc.
  4. Select the Save button.
  5. Error messgae shown: For some possible duplicates you do not have sufficient authorizations; these duplicates are shown in the list of duplicate check results ;however you will not be able to see all their details.

Cause

The user XYZ has the Buiness Role ABC assigned (ABC represents the ID of the Business Role).
This Business Role for Contacts is restricted for 2 - Assigned Territories and Employee Access.

This means the user will only be able to access the contacts which meet the above criteria.
Now when you try to create a new contact for account, and give last name of the contact (e.g. test), system finds all the potential duplicates available with name test, but due to the restriction set at business role the duplicates which are not authorized for the user will not be shown during the contact creation, hence error message shown.

However, you should be able to create the contact by ignoring the duplicate check.

 

Resolution

This is the expected behavior of the SAP Cloud for Customer.

Keywords

KBA , LOD-CRM-EMP , Employee , How To

Product

SAP Cloud for Customer 1511 ; SAP Cloud for Customer 1602 ; SAP Cloud for Customer core applications 1511 ; SAP Cloud for Customer core applications 1602 ; SAP Cloud for Customer core applications 1708 ; SAP Hybris Cloud for Customer add-ins 1708