Symptom
You have created a Service Order or a Sales Order where the output channel is XML and completed the Order. However when you go to output history tab, the button View Data XML is grayed out and you cannot see any output data.
Environment
SAP Business ByDesting
Reproducing the Issue
We will use the example of a Service Order:
- Go to the Service Order work center.
- Go to the Service Order Processing view.
- Select the relevant Service Order.
- Select View All and navigate to Output History tab
- The View Data XML button is grayed out .
Cause
Sales Orders or Service Orders can either be created manually in the system, or automatically by a business-to-business (B2B) message, or Intercompany Repair Scenario (A2A) message from an external system. In case of B2B messages, the Sales or Service Orders are electronically transferred in the form of XML messages.
Hence in B2B Scenario there will be no feasibility to see the data by selecting View Data XML.
For a manual entry, as long as the Service Order or Sales Order Confirmation is not send to the Account by selecting the Submit button and Send Order Confirmation to Account, the Output Document will not be generated and hence no Output History will be avaliable and in tune no XML will be avaiable for display.
Resolution
This is the expected behavior of SAP Business ByDesign.
See Also
Keywords
KBA , AP-SVO-SO , Service Order , AP-SLO-SO , Sales Order , How To