Symptom
In PM form template if we do some modifications and click on save, system throwing script error message.
"An application error occurred. Please try again later or copy the below error information and send it to your support group if the issue keeps occuring"
Environment
SAP SuccessFactors Performance & Goals
Reproducing the Issue
- Login to Instance
- Navigate to Admin Center ->Performance management
- Go to Manage Template
- Open the affected template
- Do some changes in the template -> Click on save
- Receive the error message.
Cause
It could be a data issue or configuration issue.
Resolution
There could be a number of reasons that the system throws an error message. However we need to do some basic troubleshooting to find the exact cause as below.
- Check if the issue persists in only one template or for all the PM form templates.
- Check the linked Goal Plan, competency id, Rating scale are valid or not.
- Check if Exponential Notation is used to set minimum or maximum value e.g. "1e+22" or "1.0E22" for fields. This is invalid configuration as this kind of value can not be processed by the system when saving the template thus application error is thrown. Instead of using Exponential Notation e.g. 1e+22, use numbers e.g. 100, 1000 etc. to set minimum or maximum value for fields. (PMU-2691)
- If everything seems to be perfect then just try to re-create the template and check. It does resolve the issue sometimes when the root cause is some data issue.
Keywords
Script error, unable to save PM template, PM Form template, Error while saving PM template , KBA , csg_q , LOD-SF-PM-FRM , Forms & Templates , Problem