SAP Knowledge Base Article - Public

2255579 - Error : Non US new hire receiving I-9 StartDate Error Message - Onboarding

Symptom

***INTERNAL USE ONLY***

When we Onboard the Candidate outside of US country we are getting an error during PHV step.

Error Message :

- The Start date you selected does not provide enough time to complete the I-9 Verification, which is required within the first three(3) days of employment. Also, the Start Date cannot be more than 30 business days from the currect date.Please return to  the panel and change the Start Date.

 

- Please verify you entered the correct Orientation Date

 

Environment

KMS Onboarding

Reproducing the Issue

When hiring a candidate outside of the US country we are getting the error in PHV step if the date format is not in European format.

I-9_Error.JPG

Cause

When hiring a candidate outside of the US country. 
1. Date format is not there in European format.
2. System should not check if StateDate meets I9 requirement

Resolution

We have to set the Date of the fields in the Panel to be required Format:

1. Login into the Onboarding.

2. Go to Setings and select the Panels.

3. Select the Date field in the Panel and set the format of the field to be required format Like if it is Country is UK then European Format.

4. Verify the same after changing the same.

5. Workaround is to change the XpressHR.StartDateUpperLimit to maximum limit of the query like 120 days in the value.

I-9_SuperAdmin.JPG

Keywords

I-9 Start Date error for Non US, I-9 error for Start Date , KBA , LOD-SF-OBD , Onboarding , Problem

Product

SuccessFactors HCM Core 1508