SAP Knowledge Base Article - Public

2255660 - SuccessFactors: API Call fails with error Authentication failed, user account is locked(status code = 13)

Symptom

API Login fails with the following error: Authentication failed, user account is locked(status code = 13) 

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors HXM Suite

  • Odata API

Cause

The account is locked due to many wrong passwords attempts.

Resolution

1. Go to Admin Center

2. Click on "Reset User Account" under "Manage Employees"

1.png

3. Search for the user and click on "Search Users"

4. Here, check the box as seen below and click on the "Reset Selected Users" button.

2.png

If the account return to lock status few time after unlocked, you need to check all systems that use this user to connect on SuccessFactors. Probably one (or more) system have a old password saved and after few connection attempt, SuccessFactors lock the account again.

See Also

SAP SuccessFactors API Reference Guide - HTTP Basic Authentication

2088598 - Will I get locked out of the system if I enter the wrong password too many times?

Keywords

Authentication failed, status code = 13, user account is locked, wrong password , KBA , LOD-SF-INT , Integrations , LOD-SF-INT-ODATA , OData API Framework , LOD-SF-INT-API , API & Adhoc API Framework , Problem

Product

SAP SuccessFactors HCM Suite 1705