Symptom
- Background Job shows 'Failed' Status.
- Background job Error message: Unable to deploy the zip file for ***.Could not write to "sftp://***.[filetype]". Please check your settings.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Go to Content >
- Import Content >
- Proceed through the tool and Schedule Job >
- An error will be seen directly after the job runs or in the Background Jobs tool.
Cause
- The content .zip file content contains server scripting extension such as .php, .asp, and .jsp file extensions. iContent SFTP is preventing those extensions from being imported.
OR - The total length of a specific file is over 255 characters long.
Resolution
- Go to System Administration >
- Background Jobs >
- Search for the Title "Content Import" and access the job that failed >
- There will be large error that will specify the filename that needs to be updated >
- If the error does not provide enough information, go to:
- System Administration >
- Configuration >
- System Configuration >
- Edit LMS_ADMIN >
- Update reportStackTraceToUser=true and repeat the import.
- If the file is a server scripting extension, please work with the content developer to update the content.
- If the file is not a server scripting extension, then the file might be too long. Reference KBA 2187183 for full SFTP guidelines. Please work with a content developer to update the file, shortening the file names and path in the error, and make sure it does not break the content.
- After reviewing the .zip file with your content vendor, import it again.
Note on content import issue with large file names:
The maximum length for the file path+name is 255 characters.
- This 255 character length limit is for the entire path on the FTP server, which includes:
- A prefix path before the customer visible path, which is not visible for the customer or external systems.
- The length of these prefixes is not identical for all different datacenters, these prefixes can be 60-80 characters.
- The path provided by the customer for the file.
- The file name.
- This limitation includes the drive letter, colon, backslash, directories, subdirectories, filename, and extension.
Shorten the file names of the ZIP file to reduce the overall characters. For example:
/learning/user/onlineaccess/icontent.do?Course=CUSTOM&url=/self-managed/supportpreview-stage/test1/CONTENTPACKAGE897173001/Testcontentfolder/kjdshglksalpowwwqqqqqqlkj/images/hjkggtttwwwrrrddbbbqqqjjssasaawwwfsdfsfgdsvdsfgsdvjdkkkdllsl/Learning-Release-Webinar.pdf
Shortened version:
/learning/user/onlineaccess/icontent.do?Course=CUSTOM&url=/self-managed/supportpreview-stage/test1/CONTENTPACKAGE897173001/Testcontentfolder/kj/images/hg/Learning-Release-Webinar.pdf
SAP Support are not trained content developers and troubleshooting 3rd party content is outside of SAP Support scope. We cannot advise on this file editing as if there are dependencies on the file names in the content it might cause issues. This is why your content vendor has to review and fix the content.
Changing the following setting will NOT resolve the above issue as it can't exceed the SFTP limit -
- System Administration >
- Configuration >
- System Configuration >
- LMS_ADMIN >
- fileUploadFilenameMaxSize.
fileUploadFilenameMaxSize configuration setting is related to Learning Management System itself only and the 255 character length limit is at STFP level. More details in the SFTP guideline KBA mentioned above. More information on the configurations available in this help file.
There is currently an enhancement request that has been acknowledged by Product Management related to file File name character length increase for the content import tool in Learning Management System you can review it here: https://influence.sap.com/sap/ino/#/idea/281513.
See Also
Keywords
lms, learning, iContent, content, upload, course, sf, SuccessFactors, could, not, write, SFTP, scheduled, job, failed, failure, fail, ContentDeploymentException, ContentDeploymentLocationBackgroundJob, FileSystemException, tool, unable, deploy, zip, file, import , KBA , LOD-SF-LMS-CNT , Content , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-BCJ , Assign (bulk), Add/ Delete Sub/ Cur, Revise, Import , Problem