SAP Knowledge Base Article - Public

2256241 - Content Import Tool - 'Imported zip does not have valid content files'

Symptom

Using the Content Import tool, after choosing to import a .zip file, the tool displays the following message: "Imported zip does not have valid content files" or "The imported zip does not contain valid content files".

Environment

SAP Successfactors Learning

Reproducing the Issue

  1. Log into HCM > access Learning Administration>
  2. Go to Content > Import Content >
  3. Choose "Add New Content" and select the required .zip file to be uploaded >
  4. Proceed through all the steps until the message on the Import Summary screen stating "Imported zip does not have valid content files" or "The imported zip does not contain valid content files".

Cause

There are two reasons this can happen:

  • When importing a ZIP file, this is going to be a AICC or SCORM content. The Import Content tool looks at the root directly of the ZIP for a manifest file (imsmanifest.xml). If the manifest file is not at the top level directory (or root) of the ZIP, then the error will be seen;
  • There are unsupported file types in the ZIP that are blocked based off a configuration in the CONTENT IMPORT property file.

Resolution

Manifest issue:

  1. Open the ZIP file on your desktop >
  2. Extract all the files into a new folder >
  3. Navigate through the files to find the imsmanifest.xml file >
  4. Select the manifest file and either move it to the root of all new folder that was created or select all files in the zip where the imsmanifest file resides and choose to create a ZIP file from there.

Note: Not all content is developed the same way and the above steps are very general. If you do not know how your content should be structured, please work with the content vendor. It is out of scope of SAP Support to assist with content ZIP files.

Unsupported file types in the ZIP file:

  1. Access Learning Administration >
  2. Navigate to System Administration > Configuration > System Configuration >
  3. Edit or View the CONTENT IMPORT property file >
  4. Find the setting unsupportedFileExtensionsInZipFiles >
  5. Make a note of the file types listed >
  6. Open up the affected ZIP file and look to see if there are any files with the extensions mentioned by the setting above >
  7. If the default file types are listed in the unsupportedFileExtensionsInZipFiles configuration, it is recommend to check with the content vendor why the file is required >
  8. Either delete the unsupported file type from the content zip or delete it from the unsupportedFileExtensionsInZipFiles configuration (not recommended).

See Also

Who Should Troubleshoot Structured Course Content

Keywords

sf, sfsf, lms, learning, admin, administration, SCORM, import, zip, valid content, Success Factors, content files, AICC, file, manifest, error, failure, extension, support , KBA , LOD-SF-LMS-CNT , Content , LOD-SF-LMS-ADM , System Admin, Global Variables, References , Problem

Product

SAP SuccessFactors Learning all versions