Symptom
Custom Field which is given Administrator only view permission does not show up under Team View Filter even thought the user has admin privilages.
Reproducing the Issue
Configure one field with “AM” role permission only. (Administrator Role)
In Executive Review page, choose “Other Filters” as filter option.
That field will be shown on page.
Change filter option to “Team View”, and update.
That field will be hidden, even if the current user has administration permission.
Cause
Variable Pay AM role doesn’t mean Variable Pay administration permission.
The following users have AM role:
- User who creates the Manager Forms.
- The managers of above user.
- In Route Map, we can define specific User Steps. The defined specific users in modify steps and signoff steps.
Resolution
This is working as expected
n Filter Options, Other Filters is different from Team View.
When we select Other Filters, if the field has at least one role, the field will be shown in exec review page. So the field with "AM" role is shown on executive review page.
But when we select Team View, and if the field only has "AM" role permission, the field will not be shown in exec review page. Because "AM" role is related to the route map of current manager form, but for exec review, it will show all manager form data together, so we can't get route map information, and "AM" role will not work.
In short, we don’t support AM role in Executive Review page.
See Also
VRP-3439
Keywords
executive review
administration
permission , KBA , LOD-SF-CMP , Compensation Management , Product Enhancement