Symptom
- Email notifications are not being sent in language other then English even if corresponding translation for the Email template exist
- Email has translation in Email Notifications Template but notification is sent in English
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Enable a different language and trigger any of email notification
- Email will be sent in English only
Cause
Language of email is determined by default language of the user, so if default language of the user is English, it will trigger email in English even if user has enabled Spanish language.
Resolution
Edit admin user who is triggering email and assign him default language in which you want to trigger emails.
For example if you want emails to be triggered in Spanish then update default language as Spanish.
There are 2 ways of updating default language for user.
Manage Users (For Non EC instances only)
- Admin tools
- Manage users
- Search for username
- Click on username to open edit window
- Select default language as required and save
Employee Import
- Go to Employee Export
- Download the latest User Data File
- Update default language (default locale) field as required
- Import the file via admin tools >Import Employee Data > Basic Import
See Also
“As of 2H 2023 you can now monitor the delivery of email notifications using Stories in People Analytics. For more details see KBA 3387145 - Reporting on the delivery of System Email Notifications”
Keywords
email notification language, wrong language, notification language, english notification , KBA , LOD-SF-PLT-NOT , Email Notifications , Problem