Symptom
- Email notifications are not being sent in language other then English even if corresponding translation for the Email template exist.
- For example if user has enabled Spanish and triggers email, notifications are still being sent to users in English.
Reproducing the Issue
- Enable Spanish language and trigger any of email notifcation.
- Email will be sent in English only.
Cause
- Language of email is determined by default language of the user, so if default language of the user is English, it will trigger email in English even if user has enabled Spanish language.
Resolution
- Edit admin user who is triggering email and assign him default language in which you want to trigger emails.
- For example if you want emails to be triggered in Spanish then update default language as Spanish.
There are 2 ways of updating default language for user.
1. Manage Users
Admin tools->Update user information->manage users->search for username->click on username to open edit window->select default language as required and save.
2. Employee Import
Export user data file.
Update default language field as required.
Import the file via admin tools->update user information->Employee import.
Keywords
KBA , LOD-SF-PLT-NOT , Email Notifications , Problem
Product
SAP SuccessFactors platform all versions