SAP Knowledge Base Article - Public

2257888 - No Result Returned by External Provider VERTEX

Symptom

You have enabled VERTEX tax calculation on this system.

You are trying to execute a supplier invoice, customer invoice or create a goods and service receipt, but the following error messages prevent you to complete the document:

  •  No result returned by external provider
  •  Vertex Error 

Environment

SAP Business ByDesign

Reproducing the Issue

In the example of a customer invoice, the error is checked as follows:

  1. Navigate to the Customer Invoicing workcenter. 
  2. Go to the Invoice Documents view. 
  3. Search for the ID ABC (Where ABC is the Customer Invoice ID).
  4. Click on Edit.
  5. Click on View All.

The error messages are displayed.

 

Cause

An incorrect ZIP code has been maintained on the customer/supplier master data.

It's necessary that the ZIP code maintained on the master data is correct and consistent. It is possible to confirm it using Vertex online tool to check zip code validity and confirm tax rates via the following link:

Resolution

To correct a supplier master data, perform the below steps:

  1. Supplier Base work center
  2. Go to Suppliers view
  3. Find supplier XYZ
  4. Select supplier and click Edit and select Addresses
  5. Correct ZIP code and save your changes

In order to correct a customer master data, perform the following actions:

  1. Account Management work center
  2. Go to Accounts view
  3. Find account XYZ
  4. Select account and click Edit and select Addresses
  5. Correct ZIP code and save your changes

In case the ZIP code is correct, please report an case to SAP for further analysis.

Keywords

Vertex, No result returned by external provider, taxes, customer invoice, supplier invoice, supplier, master data, customer, account, goods and service receipt, Vertex error, byd. , KBA , AP-TTE-TC , Tax Calculation , How To

Product

SAP Business ByDesign all versions