Symptom
Certain users receive one of the below errors when running Report - Table reports online:
- HTTP Status 401 – The authentication of the user failed
- The report cannot be generated because user is not authorized to access it.
Please contact your SuccessFactors Administrator to resolve permissions for the user. - Exporting the report offline as CSV will fetch expected results
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors HXM Suite
- Table Reports
Reproducing the Issue
- Navigate to Table reports in the Reports Center as the affected user
- Click any report and select 'Run Report'
- Choose the 'Run Online' option and Generate the Report
or
Cause
- Lack of 'User Login' permission in RBP
- Locked User account
Resolution
- Modify 'General User Permission'
- Admin Center> Set User Permissions> Manage Permission Role> Select the desired Role> General User Permission
- Grant 'User Login' permission and save the changes
- The user will have to re-login for the changes to take effect
-
In admin Center, there is link called “Reset user account"
-
If it is showing cancel icon in red colour, reset the user account which will change to tick mark in green colour
Keywords
Ad, Hoc, Report, Table, authentication, not, authorized, unable, HTTP Status 401, Report, Center, Report, Table , KBA , 401 ad hoc , LOD-SF-ANA-ADH , Adhoc Reports & Report Builder , Problem
Product
SAP SuccessFactors HCM Suite all versions