Symptom
- When attempting to edit or run a 'Live Data' report in ORD, it loads for some time and fails with a Rendering error.
- This happens both in List reports and Pivot Queries
- The following logs are captured in the Analytics server:
ExceptionStatus: Timeout, Exception: The operation has timed out, RequestContent: . ---> System.Net.WebException: The operation has timed out - Go to Edit query mode for the affected component > The table will display data preview results.
Environment
- SAP SuccessFactors People Analytics
- Report-Canvas (Detailed reporting)
Reproducing the Issue
- Navigate to Online Report Designer
- Attempt to edit or run a 'Live Data' report in ORD
Cause
There is a time-out limit set, for running an online report in ORD:
- This is done , since the same servers are used for both transactional as well reporting purposes.
- If a query runs for more than this time, it will cause issues with other jobs in the server.
The report's run time depends on multiple parameters. Examples:
- Number of columns and rows (amount of data)
- Cell level permissions
- User’s target population
- Server load
The Edit query view only queries the top 100 rows and will not time out due to sheer volume of records (though query complexity may still cause timeouts) but the Run Report Online attempts to render the entire query. If it is too large it will not complete.
Resolution
Any report that takes more than 5 minutes to load should be run using the Report Distributor to run offline.
To view the complete results, add the report to a bundle in Report Distributor and select Run Offline. You will be able to download the export from Report Distributor Downloads, and timeouts will not be a concern.
Keywords
ARB timeout, Online Report Designer, Canvas timeout, Canvas error, huge queries, large reports , KBA , LOD-SF-ANA-ORD , Online Report Designer , Problem