Symptom
System requires postal code in the account address which was not mandatory before. In this case, country SA - Saudi Arabia.
Reproducing the Issue
- Go to Customer Invoice work center.
- Go Sales Order View.
- Find the sales order and click on New tab and select Manual Project Invoice Request.
- Now go to step 5 Refine Invoice Items, system throws the error: Enter a postal code.
Or, when you edit the account master data, the error shows up.
However, it was working fine without error.
Cause
There was a system change and the case is country sensitive. For exmaple, the country SA is not required Postal Code as mandatory before the change, so the creating of project invoice request without postal code was fine. But as per the new requirement legally, country SA requires the postal code as mandatory information in address, so system changed accordingly due to the legal requirement.
Resolution
For the exisitng documents without postal code, you can remove this check (on postal code) and continue the creation of invoice request.
- Go to the Business Configuration work center.
- Go to the Overview view.
- Search key word Countries and click Go.
- Select the activity and click Open.
- Click Edit Countries link and select for example country SA.
- Go to the Postal Atributes tab, Now we have removed the flag for postal code.
Afterwards, you should process the documents with the accounts which has no postal code maintained.
Keywords
KBA , postal code in the account address , AP-CI , Customer Invoice Processing , How To