Symptom
Survey answers maintained in the surveys are not being reflected in the report 'Business Partner Survey: Customer Satisfaction Answers' and data source 'Business Partner Survey Answers'.
Environment
SAP Cloud for Customer
Reproducing the Issue
1. Go to Business Analysis Work Center.
2. Go to Design Reports Work Center View.
3. Open the report 'Business Partner Survey: Customer Satisfaction Answers'.
It shows the message 'No report data available to display; check the selection' even though when below conditions are met:
Cause
The standard report 'Business Partner Survey: Customer Satisfaction Answers [QREVQVBUPARJ_Q0001]' has a global restriction as per which the logged in user will be able to see the responses of only those surveys which are responded by the customers (& contacts) for which he is responsible for or related to.
When we say the respondent of the survey should be related to the logged in business user, it means that:
1) Either the logged in user should be the responsible agent of the respondent
2) Other employees belonging to the same sales unit who have same position as the logged in user, should be the responsible agent of the respondent
3) Or functional unit managers, who belong to the logged in users subordinate sales units, should be the responsible agent of the respondent.
Observations:
1. Surveys are maintained with active status for category satisfaction
2. Sales Campaign -> Enhanced Sales Campaign Functionalities is scoped in the Business Configuration setting under Scoping.
Resolution
In order to see the data in the report the Satisfaction Surveys should be filled as mentioned above or alternatively, you can try creating a custom report on the data source Business Partner Survey Answers [QREVQVBUPARJ].
Keywords
QREVQVBUPARJ_Q0001, Business Partner Survey: Customer Satisfaction Answers, BUSINESS PARTNER SURVEY. , KBA , LOD-LE-SUR-ANA , Survey Analytics , How To