Symptom
Custom fields don't appear as a rule attribute during Dynamic list creation.
Environment
SAP Jam Collaboration
Reproducing the Issue
- As a Company Admin in SAP Jam, navigate to Admin-> Users -> Member Lists.
- Select the Dynamic Member Lists tab and click New Dynamic Member List.
- In the Rules tab, try to select a custom field as the membership criterion.
- The custom fields don't appear in dropdown.
Cause
This is caused due to the Jam admin user lacking sufficient permissions in BizX.
Resolution
For the custom fields to be visible in Jam Dynamic List rule creation section, the following permissions requirements need to be met in BizX RBP->
- Inside the Permission Role, Jam admin need to have Company Info Access permission plus sub-permission User Search (this permissions can be found inside the section General User Permission of a Permission Role);
- The Jam admin should have at least View permission for all the concerned custom fields under the Employee Data section in RBP.
- The Target Population of the above permission should be All Employees.
Only when all above conditions are met, the custom fields will be available for dynamic list rule creation.
Alternately, instead of having the Company Info Access + User Search permission, if the Jam Admin user has the Employee Export permission with the target population for All Employees, that will also work along with the Employee Data fields permission.
Note: Any permission change in BizX RBP can take up to 20-30 mins to reflect in Jam.
Keywords
Jam Dynamic List, Jam Custom Field, Jam Permission for dynamic list , KBA , LOD-SF-JAM , SAP Jam , Problem