Symptom
Sales orders and Service Orders created via the web service are still in status In Preparation even though the following scoping questions was set to No: Would you like your employees to control the release of sales orders that originate from an E-Shop in order to initiate order processing?
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Business Configuration work center.
- Select the Implementation Projects view.
- Select the respective implementation project.
- Click on the Edit Project Scope button.
- In Scoping, go to the section Questions.
- Select the following path Sales -> Selling Products and Services -> E-Selling
- In the section Questions: Sales Order Release Procedures the following question is set to No:
- Would you like your employees to control the release of sales orders that originate from an E-Shop in order to initiate order processing?
You expect that the sales orders will be released automatically. In this case we have taken example of Sales Order but the system behavior is same for Service Orders as well.
Cause
The reason why the sales orders created via the web shop are not released automatically is due to either:
1. You have set up an approval process for sales orders. This means that when you create a sales order via the web service and if you have scoped and sent up the approval for sales orders in the system, then sales order will not get released automatically since the Submit For Approval action is required first. This works differently from the UI (User Interface) because we have a Submit Button on the UI which is mapped to the SUBMIT FOR APPROVAL and RELEASE action subsequently.
2. You are passing the element DataOriginTypeCode not as 4 (Internet).
3. The Sales Order is inconsistent and is with errors.
Please note: The tag <ReleaseCustomerRequest> only controls the technical status and is not related to the actual releasing of a sales order (Submit->Release order on the UI) which changes the status of the order from In Preparation to Open which is controlled via the fine tuning question.
The tag <ReleaseCustomerRequest>true</ReleaseCustomerRequest> is only relevant if the following scoping Question is active:
Would you like your customers to confirm sales orders that originate from an E-Shop with information calculated in the SAP solution?
In this case in your first call you would pass the ReleaseCustomerRequest as false to avoid that the order will appear in the UI for processing. When the customer confirms the sales order in the E-Shop you would send a second call with the ReleaseCustomerRequest as true to make it visible in the UI for processing.
Resolution
This is the expected system behavior.
In case point 1 applies:
Please evaluate if you require this approval process. If you don’t need the approval process you can un-scope the Sales Order Approval Process and the sales orders will then be automatically released. Should you require the Approval Process, you need to pass the DataOriginTypeCode as 4 and the SendConfirmationIndicator and the ReleaseCustomerRequest as true.
<DataOriginTypeCode>4</DataOriginTypeCode>
<SendConfirmationIndicator>true</SendConfirmationIndicator>
<ReleaseCustomerRequest>true</ReleaseCustomerRequest>
For Service related items you need to also pass the ReleaseAllItemsToExecution as true:
<ReleaseAllItemsToExecution>true</ReleaseAllItemsToExecution>
In case point 2 applies:
Please pass the element DataOriginTypeCode as follows:
<DataOriginTypeCode>4</DataOriginTypeCode>
In case point 3 applies:
You need to ensure that the Sales Order is created consistent without any errors.
Keywords
ReleaseCustomerRequest; Sales Order; ManageSalesOrderIn; web service; webservice; status; released; ManageServiceOrderIn; Service Order; E-Shop; Customer Release of Internet Orders; Employee Release of Internet Orders; , KBA , AP-SLO-SO , Sales Order , How To