Symptom
- When searching for an user using their first and surname, only the first name is being shown in the search insteal of the full first and surname
- Happens when 'Enable Name Format' is enabled in Provisioning
- How to fully configure Name Formatting in SuccessFactors Employee Central
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors Employee Central
- Employee Central
Reproducing the Issue
- Login to instance
- Search for an employee using first and surname
- Only first name shows up even though user has first name and surname.
- In provisioning 'Enable Name Format' is enabled.
- Then issue exists
Cause
If enabling the name format function for the first time during or after the Q2 2015 release then issue will occur.
Resolution
- Go to Admin Center, and in the Tool Search on the top right-hand side of the screen, enter Configure Object.
- Definitions and search. This will take you to the Configure Object Definitions screen.
- In the Search field, select Object Definition, and in the adjacent field, select Legal Entity.
- On the right hand side of the screen, on the Take Action menu, select Make Correction.
- Create a new association with the details highlighted in the screenshot below, then select Save.
- Now associate value of 'name format' in 'Legal entity' in 'Manage Data'
Keywords
SF, Success Factors, EC, people search, surname , KBA , LOD-SF-EC , Employee Central , Problem
Product
SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions