Symptom
When setting up an onInit rule for the field 'Benefits Eligibility Start Date', 'Service Date' field, the rule does not trigger/change the value from the Hire Date field during the new hire wizard.
Environment
- SAP SuccessFactors HCM Cloud
- Employee Central
- Business Rules
Cause
The onInit rule type will not work for the 'Benefits Eligibility Start Date' field or 'Service Date' as the field has hardcoded logic to set it equal to the Hire Date field. If a rule is setup, the value will be overwritten with the Hire Date field value due to the hardcoded logic.
Resolution
This is expected behavior due to hardcoded logic to convert this field to the Hire Date field value. A workaround can be used to set the field visibility to none and then setup a custom-date field with the same label of 'Benefits Eligibility Start Date' or 'Service Date'. This custom field can then be configured to use a rule as necessary during the new hire process.
Keywords
onInit rule, EC, NewHire, ECT-46952 , KBA , LOD-SF-EC-EMP , Employment Information (Employment Details) , LOD-SF-EC , Employee Central , Problem