Symptom
When trying to import a Competency file, the file fails with an error:
name.#: Exceed text size limit [128].
Environment
SAP SuccessFactors Job Profile Builder
Reproducing the Issue
- Log in to SuccessFactors
- Navigate to Admin Center > Manage Job Profile Content Import/Export
- In the Type dropdown, select Competency
- Select Browse > select your .csv file
- Navigate to Admin Center > Scheduled Job Manager
- Locate the failed job and select View Details
- Open the file and the error is present
Cause
The name field exceeds the system-defined 128-byte limit
Resolution
The error tells you which language description exceeds the 128-byte count e.g., name.zh_CN. The competency name will need to be reduced to 128 bytes or less before the file can be imported.
NOTE: Some languages have double byte characters e.g., Traditional Chinese, Simplified Chinese, Japanese, Korean.
Keywords
Error, Competency, Import, JPB, success factors, competencies, names, imports, importing, failure, fails , KBA , LOD-SF-TIH-JPB-ADM , Admin Center, Settings, Permissions , Problem