Symptom
When importing the NationalIDCardImport template or updating National ID portlet or hiring a user, either of the following errors appears:
- Country Specific XML does not have format defined for National ID type **** for country ***
- Country Specific XML file does not have configuration for Country ***
- In the country/region-specific XML file, define a format for national ID type *** for ***
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors HXM Suite
- SAP SuccessFactors Employee Central
Reproducing the Issue
Scenario 1: Import
- Go to Import employee data
- Select National ID Information and incremental load
- Import the National ID template with the details
- The error "In the country/region-specific XML file, define a format for national ID type Social Security Number for USA" is presented
Scenario 2: Add New Employee
- Navigate to Admin Center
- Search for Add New Employee tool in the Tool Search
- Add National ID information
- Click on Next
- An error is received: Country Specific XML file does not have configuration for Country ***.
Cause
This error is caused by one of the following reasons:
- A custom picklist is added to the country, national id field, and national id card type field.
- There are hris-section's maintained in the CSF Succession Data model, but there are no hris-sections maintained in the Succession Data Model
- The country(s) are not configured in the CSF Succession Data model.
- The National ID Card type used is incorrect. Using the label of the card type, such as Social Security Number, is not supported.
Resolution
To resolve your issue, please carry out the below steps for the corresponding cause of the issue:
- A custom picklist cannot be added to the Country, National Id Card Type, and National id fields. Remove all the custom picklists associated with each of these fields in Manage Business Configuration tool (BCUI).
- Remove the hris-sections from the CSF Succession Data Model (CSF SDM) and reimport it. If you are a customer, please reach out to your partner or Technical Support to have this actioned. You can download the CSF SDM from Admin Center > CSF Succession Data Model, however you cannot upload it. If you want Technical Support to upload it, please provide updated CSF SDM in the ticket.
- When performing a National ID information import we need to add the identifier in the national ID card type field and not the label.
If we use the import file below, with card-type ssn instead of Social Security number(identifier instead of label), we have no issues during import.
- If you have corrected previously configured incorrect configuration for National ID and now you're getting error "In the country/region specific xml define a format for national id type *** for ***" while attempting to correct/delete exisitng National ID data, you need to perform Compound Import for deletion of the incorrect existing data. You can find more details about Compound Import here: 2786737 - How to delete an orphaned Person ID with Compound Delete functionality or Deleting Employee Data with Multiple Entities.
See Also
2701612 - How to Import National ID Information
2923091 - Error: National ID XYZ already exists for country/region ABC and card type MNP
2093378 - National ID validation issues - Employee Central
2526193 - Manage Business Configuration: How to Create or Edit National ID Card formats in BCUI
Keywords
National ID info, National ID card type, import error, identifier, nationaID, error faced, facing issue, Country Specific XML does not have format defined for National ID type, country/region-specific, validation, check, validate, upload, new hire, hire, hiring, edit, save, CSF, section, exception, delete, remove, correction , KBA , LOD-SF-EC-PER-NAT , National ID - Config, Rules, RBP, UI , LOD-SF-EC-PER , Person Data (All Person Data Types) , Problem
Product
Attachments
NationalIDimportCODES.xlsx |
NationalIDimportCODES.xlsx |