Symptom
It is not possible to edit the field Territory in the Account Quick Create window. After un-checking the Read-Only flag in properties, the field stays Read-Only.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Customers Work Center.
- Go to the Accounts View.
- Click New.
- The Territory Field is Read-Only (cannot be manually edited).
- Click Adapt > Edit Master Layout > properties icon for the field Territories > un-check the Read-Only checkbox > Add > Leave Adaptation Mode.
Result: the properties have gone back to being Read-Only and you cannot edit the field.
Cause
Development made the system like this to discourage the manual territory assignment. Manual Territory Assignment is considered to be the exception and not the standard way.
Resolution
To have the Field Territory editable during the account creation, you need to have the Checkbox Override Territory checked.
Keywords
Territory, Read-only, read only, properties, mandatory, Account, new, quick create, adapt , KBA , LOD-CRM-TM , Territory Management , How To