SAP Knowledge Base Article - Public

2270342 - Follow-up / Course Feedback Survey not sent following item completion

Symptom

Follow-up / Course Feedback Survey is not assigned to users after they complete the item the survey is associated to.

Environment

SAP SuccessFactors Learning

Reproducing the Issue

  1. Set the required item to trigger Follow-up / Course Feedback Survey upon the item completion
  2. The item is completed by the user but the Survey is not triggered

Cause

Such an issue could be caused by :

  • a missing setting on the Completion Status level.
  • if records learning history based on Class ID and records before the Class ends, the follow-up survey won't show on Learning Plan until the class ended.

Resolution

  • To check Completion Status settings:
    1. Under Learning Administration -> References -> Manage User Learning -> Completion Status
    2. Search for the Completion Status used and click Edit to open the record
    3. Select the setting "Include learning events with this completion status for Course Feedback Survey Assignment" and click Apply Changes.
    4. Select the setting "Include learning events with this completion status for Follow-Up Survey Assignment" and click Apply Changes.
  • After the class ended, the follow-up survey will show on Learning Plan automatically.

Keywords

SAP, SF, LMS, SuccessFactors, Followup, survey, completed, triggering, trigger, assigned, item evaluation, follow up, Course Feedback , KBA , lmsadminui , LOD-SF-LMS-EVA , Surveys , Problem

Product

SAP SuccessFactors Learning all versions