Symptom
Follow-up / Course Feedback Survey is not assigned to users after they complete the item the survey is associated to.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Set the required item to trigger Follow-up / Course Feedback Survey upon the item completion
- The item is completed by the user but the Survey is not triggered
Cause
Such an issue could be caused by a missing setting on the Completion Status level.
Another possible cause is that the Course Feedback and Follow-Up Surveys e-mail Notification APM is not scheduled and/or has errors.
You can check this APM following these steps:
- Learning Administration
- Automatic Processes
- Course Feedback and Follow-Up Surveys e-mail Notification
This automatic process performs two tasks:
- It sends survey assignment notifications for both Course Feedback Survey and Follow-up Survey.
- Assigns Follow-up Surveys to Users and their supervisors based on the assignment period configured for the Item.
This automatic process uses the ItemEvaluationAssignmentNotification template to send Item Evaluation e-mail notifications to the affected users and uses the FollowupEvaluationAssignmentNotification template to send e-mail notification to Follow-up Evaluation participants.
Resolution
- Under Learning Administration -> References -> Manage User Learning -> Completion Status
- Search for the Completion Status used and click Edit to open the record
- Select the setting "Include learning events with this completion status for Course Feedback Survey Assignment" and click Apply Changes.
- Select the setting "Include learning events with this completion status for Follow-Up Survey Assignment" and click Apply Changes.
Keywords
SAP, SF, LMS, SuccessFactors, Followup, survey, completed, triggering, trigger, assigned, item evaluation, follow up, Course Feedback , KBA , lmsadminui , LOD-SF-LMS-EVA , Surveys , Problem