Symptom
- Error when refreshing a report connecting to Salesforce.com
- Other reports based on Salesforce.com refresh successfully in Crystal Reports. The error only occurs with specific reports.
- When refreshing some report based on Salesforce.com in Crystal Reports, it fails with the error:
"Failed to retrieve data from the database.
Details: HY000:OPERATION_TOO_LARGE:Exceeded 100000 distinct ids [Database Vendor Code 108]"
Environment
- SAP Crystal Reports 2013
- SAP Crystal Reports 2016
Reproducing the Issue
- In Crystal Reports, create a report based on Salesforce.com
- When refreshing the report, it fails with the error:
"Failed to retrieve data from the database.
Details: HY000:OPERATION_TOO_LARGE:Exceeded 100000 distinct ids [Database Vendor Code 108]"
Cause
- As the error indicate, this error occur because the data set is too large. This is a Salesforce.com limitation documented in the following Salesforce Knowledge Article:
212083 - Why am I getting the "Operation too large" error message when running a report?
Resolution
- Salesforce suggestions are:
- Refine the filtering criteria to reduce the amount of data; or
- Add the permission "View All Data" to the Salesforce.com user.
- For more details, see Salesforce Knowledge Article: 212083
- For questions on the above suggestions, contact Salesforce Support.
Keywords
CR, SForce, Saleforce, limit , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem
Product
SAP Crystal Reports 2013 ; SAP Crystal Reports 2016