Symptom
Employees could previously view their private profile view by the drop down menu list. In this case the private profile view choice was not available.
The permission role associated with user showed the "Private Profile" employee view was checked as viewable.
Cause
In this case the problem was caused by an incorrect setting in the "Grant this role to.." UI of the permission role. Clicking on "Edit Granting" action revealed the "Exclude Granted User" checkbox was checked causing the Private profile to not be displayed for users for whom this permission role was the only role where the Private Profile view was granted permission. Users associated with other permission roles where the Private Profile view was granted permission and did not have the "Exclude Granted User" checkbox checked could see the Private Profile.
Resolution
Unchecking the "Exlude Granted User" checkbox in the "Grant this role to..." UI and saving resolves the problem.
View Menu After Unchecking the "Exclude Granted User" checkbox:
Keywords
KBA , LOD-SF-EC , Employee Central , Problem