Symptom
An error occurred while inserting or updating a JobApplication entity or any of its related entities (e.g. JobApplicationAssessmentOrder, JobApplicationBackgroundCheckRequest, etc) in the recruiting module of SuccessFactors using OData API.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
1. Make an update call to the successfactors instance using Job Application API entity SFOData.JobApplication or any JobApplication related entities
2. You see the following error in the response:
{ "d" : [ { "key" : "JobApplication/applicationId=###", "status" : "ERROR", "editStatus" : null, "message" : "Recruiting OData API Application Create/Update permission in Admin Center is not enabled", "index" : 0, "httpCode" : 403, "inlineResults" : null } ] }
Cause
This is because of the incorrect permissions assigned to the user which is being used to update/insert the application via API call.
Resolution
Odata permissions are split based on the entity and operation to be executed. For this specific case, the error happens due to missing creation (insert) or update missing permission for the Job Application entity or its related entities.
1. Logon to successfactors System.
2. Go to admin center.
3. Choose "Manage Permission Roles".
4. Select the respective role assigned for the user used to update the Job Application.
5. Now click on Permission and click on Recruiting Permissions and check the following permissions, based on your business requirement:
If the same Job Application update is done via Boomi, the following error can be seen in the process logs
Keywords
OData, Error, Boomi, JobApplication , KBA , create/update permission in admin center , input bd json array[1] not found , LOD-SF-RCM-API , Webservices & APIs , LOD-SF-INT-API , API & Adhoc API Framework , LOD-SF-INT-BOM , Standard SF to 3rd Party Boomi Content , Problem