Symptom
When importing a Time Off request, or submiting it via the UI, an error occurs preventing you from submiting this absence request
"There are already absences for [USER NAME] in period [DATES], so this posting is not possible"
Reproducing the Issue
- Login into the instance
- Navigate to Employee Files
- Select Manage Time off
- Under Time Off Overview click Request Time Off
- Select time type and dates and submit
"There are already absences for [USER NAME] in period [DATES], so this posting is not possible"
The same error message will show if you try to submit the above time request via employee time import.
Cause
You cannot have two time requests on the same day. Even if these two requests have distinct time types (such as one Vacations and the other Sickness Leave), the current system behaviour will not allow the posting.
If the time off request includes more than one day please make sure that all days in your request do not overlap with any other existing requests, even if the time type is not the same.
Resolution
This is system expected behaviour.
As a possible workaround please note that since b1511 we have introduced clock times. With these it is possible to have two absences on one day, however still, they are not allowed to overlap. E.g. you can take off from 13.00 to 17.00 in the afternoon and then add another absence for 08.00 to 10.00 o'clock.
Keywords
Time Off, Absence Management, Leave Request, Error, Employee Central 2.0, There are already absences , KBA , LOD-SF-EC-TIM , Time Off , How To