Symptom
The items to be invoiced based on the same Sales Order cannot be combined into one invoice. The system splits the invoice into two invoices.
Environment
SAP Business Bydesign
Reproducing the Issue
- Go to the Customer Invoicing Work Center.
- Select the Invoice Requests View.
- Filter for All Invoice Requests.
- Select the respective To Be Invoiced Invoice Requests which are based on Sales Order XYZ (XYZ represents the number of the Sales Order).
- Select Invoice button.
In the New Invoice window, the items are split into two invoices instead of combining them into one customer invoice as expected.
Cause
The reason the invoice split occurs is due to the extension field being different in both the invoice requests. When invoicing an Outbound Delivery Invoice Request, we merge the Sales Order Invoice Request and the Outbound Delivery Invoice Request together.
For the extension fields, we give preference to the values that are on the Outbound Delivery Invoice Request over the Sales Order Invoice Request, this relevance can be well observed in item types like Product - delivery-based,Service - fixed price without actuals etc.
For the Sales Order Invoice Request, we do not merge it with any other invoice request and the extension fields that exist on the Invoice request will be on the Customer Invoice.
In this case, the extension fields are filled on the Outbound Delivery Invoice Request and these fields are not filled on the Sales Order Invoice Request. Hence the difference causes the invoice to split.
Resolution
This is the expected system behavior.
See Also
1500875 - Split Criteria in Customer Invoicing
1937053 - Split Criteria in Customer Invoicing for India
1935518 - Invoice Split Due to Difference on Seller Tax Number
Keywords
invoice split; extension field; invoice request; sales order invoice request; outbound invoice request; customer invoice , KBA , AP-CI-CIR , Customer Invoice Request , How To