Symptom
SAML2 error occurs when accessing objects from Feeds.
Environment
SAP Cloud for Customer
Reproducing the Issue
In the below steps, Appointments are used as an example.
- Go to the Activities work center.
- Go to the Appointments View.
- Search for appointment XYZ (XYZ represents the ID of the appointment).
- Create a new comment on appointment XYZ.
- Go to the Feeds work centre.
- Try to open appointment XYZ from the feed post by clicking the link.
- Error appears: SAML2-Service not reachable.
Cause
The user has logged in with SSO however the link opens is Non-SSO which is causing SAML 2.0 error.
Resolution
Ensure below pre-requisites are fulfilled:
- Within scoping under JAM integration - you should select the option to use SSO URL.
- Once done, then all feed links have SSO URL.
- The user should have logged in via SSO to the C4C system and when user clicks the link, it directly opens the object without any prompt for login.
Steps to do do the scoping changes:
- Go to the Business Configuration work center.
- Go to the Implementation Projects view.
- Select the project and choose Edit Project Scope.
- Go to the step 4: Questions.
- Expand Communication and Information Exchange.
- Expand People Collaboration, Intranet and External Services.
- Select Communities, Document Management and External Services.
- Scope the question 'Do you want to use C4C SSO URL for Jam Integration?'.
- Review and Finish the changes.
Keywords
Jam, SAML, SSO, authentication, error, login, feed, link, access, appointment, opportunity, sales quote, url, , KBA , LOD-CRM-SRP , Service Request Processing , LOD-CRM-IN-JAM , JAM Integration with Cloud for Customer , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions