SAP Knowledge Base Article - Public

2277915 - Employee Central Advanced Reporting: Standard Reports Headcount and FTEs not working as expected

Symptom

You have just uploaded successfully the EC Standard Report Template to your instance, the validation checks confirms is all ok, but notice that when you try to run/preview the report the below message is shown:

[Role based security prevents the viewing of this component]

Role Based error.jpg

When you edit the report/query, after copying the report, you notice that on the Pivot screen an error is shown when you select Show Design View:

[Error in rendering table] 

Error rendering table.jpg

Environment

  • Employee Central Advanced Reporting
  • EC Standard Reports Template

Reproducing the Issue

  1. You successfully upload the Standard Report Templates for Advanced Reporting
  2. You validate the report accordingly and everything is fine
  3. When you try to run/preview the report, Headcount and FTEs for this example, data is not shown and the message Role based security prevents the viewing of this component appears
  4. In edit mode, right click on the message then select Edit Query. This will open the Pivot screen where you can see the measures, rows and columns fields.
  5. If you switch to Show Design View and error is shown: [Error in rendering table]
  6. Click on the Edit query Icon Query icon.jpg to check the query
  7. From the query (Realm) result you can see that data is correctly shown without errors.
  8. When you check the query result further, for this example, the Service Date and Length of Service are empty while they should have data.
  9. Service Date & Length of Service.jpg
  10. Drilling down further to the Length of Service calculated column formula it shows that it is based on the Hire / Service Date calculated column which uses the Service Date field.
  11. Calculated Columns.jpg
  12. Length of Service.jpg
  13. Service Date.jpg
  14. In this case, this field is not available for Advanced reporting when we select a new query from scratch. 
  15. Service date missing.jpg

Cause

System behaviour as designed.

Issue was caused by the required adjustments to the report query and Pivot measures.

Resolution

For this case, the reason of the error messages were mainly due to the unavailable field Service Date and the Pivot Measures available with the EC standard template.

The issue was solved by reconfiguring the Pivot Measures from scratch.

This can be done as following:

  1. From the Pivot screen select edit next to the measure and take note of the settings. e.g. Pivot measure name and Pivot Function 
  2. Identify which measure/field generates the error. I was able to identify the incorrect measure by removing one measure at the time and by switch to Show Design View
  3. Once the erroneous measure is identified and removed you can then recreate the measure by dragging the field from the left menu to the measure section
  4. when the Show Design View is error free and data is shown you can select ok
  5. The report preview should work and return data accordingly

NOTE: in this case, it was not possible to recreate the Average Length of Service measure since it was based on a calculated columns which did not have a mandatory field available (Service Date) and because the field did not contain data.

Keywords

KBA , LOD-SF-ANA-ADV , Advanced Reporting (ODS) , LOD-SF-EC-REP , Reporting Data (EC core only) , Problem

Product

SAP SuccessFactors HCM Suite all versions