SAP Knowledge Base Article - Public

2278274 - You Can Save An Opportunity Which Has A Product Category But No Product

Symptom

You are able to save an Opportunity although you have only added a Product Category, no an actual Product.

Reproducing the Issue

  1. Go to the work centre Sales.
  2. Go to the view Opportunities.
  3. Select an Opportunity ABC (ABC represents the name of the Opportunity).
  4. Go to the facet Products.
  5. Click Add to add a row for Products.
  6. Select and add a Product Category 123 (123 represents the name of the Product Category).
  7. Click Save.

Result

The save is successful.

Cause

This is expected system behaviour.

It is possible to add an item in an Opportunity by one of following three ways:

  1. Add product
  2. Add only product category
  3. Add only description (user text)

This flexibilityis provided for users who may not always know the exact product that has to be sold.

 

Keywords

KBA , SRD-SRM-PRP , Product Portfolio , How To

Product

SAP Cloud for Customer 1511 ; SAP Cloud for Customer 1602 ; SAP Cloud for Customer core applications 1511 ; SAP Cloud for Customer core applications 1602 ; SAP Cloud for Customer core applications 1605 ; SAP Cloud for Customer core applications 1708 ; SAP Hybris Cloud for Customer add-ins 1605 ; SAP Hybris Cloud for Customer add-ins 1608 ; SAP Hybris Cloud for Customer add-ins 1611 ; SAP Hybris Cloud for Customer add-ins 1702 ; SAP Hybris Cloud for Customer add-ins 1708