Symptom
User Sync is not working, and users are not syncing from BizX to Onboarding 1.0.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental
Environment
SAP SuccessFactors Onboarding 1.0
Cause
- Sync between BizX and SFTP Fails (for example file is not generated, and placed in SFTP)
- Sync between SFTP and ONB Module (for example file is placed in SFTP, but it's not picked up by Onboarding)
- User Sync job corrupted in Provisioning and not being executed properly.
Resolution
Scenario 1: User sync file not getting sent to SFTP
- Provisioning
- Manage Schedule Jobs
- Filter by Ad hoc
- Check that the job is present
- Check if the job is submitted, if job is not submitted that is the reason why it is not going to SFTP
- If submitted, and not going to SFTP
- Click the job name to open it
- Check that the File available in FTP? option is checked, because that is the option that sends the file to SFTP once it has been submitted
- "Report format" should be CSV, otherwise even onboarding 1.0 takes the file, content cannot be read.
- Image below is what a configure job in provisioning looks like
Scenario 2: Files are going to SFTP, but are not being picked by onboarding.
- Provisioning
- Company setting
- Check for Onboarding Account ID
- Super Admin
- Find account
- Feature
- Foundation Import
- If the foundation import feature is enabled, ensure that the SFTP folder is correct and the host address,
Cause 1: File name is not matching
- Run user sync job and go to SFTP to take the CSV file
- Go to Super Admin >>Import/Export Settings >> FoundationImport
- Check <FileMask>{AccountName}_User_Sync_*.csv</FileMask> with the name of csv file taken from SFTP
- Please pay attention to upper/lower case and "_"
- To resolve the mismatching, need to correct the file name in user sync job or <FileMask> in FoundationImport file.
Cause 2: foundation import job is not running
- @Support engineer please search in logs with keywords: ONB account id + FoundationImportJob
- In case no logs for last 24 hours or errors, please ask for approval and SFTP credentials to disable and re-enable the foundation import feature. (take a screenshot before disabling as a backup)
- If still no luck, please turn to senior members and consider to raise internal incident to Ops team.
If the above are completed and the file is still not getting picked up
- Open the report in SFTP check the row headings on the report
- Navigate to Super Admin
- Import Export Settings
- FoundationImportFieldMapping
- Export the files and check that the value of the columns on SuccessFactorsUserImport
- Matches the name of the row headings on the report
- Job Owner is visible on sync in Provisioning:
- If you want to view the job in BizX you must proxy the job owner to view the report in analytics.
Tips:
- Keep the job owner’s default language in BizX as English otherwise the Onboarding the job will not be picked up otherwise.
- Do not alter the ImportUses file in Super Admin
- Do not add the Onboarding account name in the Foundation Import file on FileMask row.
- Ensure to leave the default as shown below
Scenario 3: User Sync job corrupted in Provisioning and not being executed properly.
Please re-create it from scratch, then run it manually once and check if it completes, if the file generates in the SFTP and if it will be consumed by onboarding after a while.
Note: while re-creating the job, make sure that it has the same settings as configured in SuperAdmin > Features > Foundation Import.
Note: If the jobs are configured correctly and the file is being picked up from SFPT, but the seamless login error still persists, please create a support ticket. We will then raise a ticket to operations to clear the cache.
Keywords
SF, success factors, OBD, ONB, User Sync, File is not picking up from SFTP, File is not generated in SFTP , KBA , LOD-SF-OBD-FIM , Foundation Import (User - Permission - Corp Sync) , LOD-SF-OBD-INT , Integrations with Onboarding , Problem