Symptom
You change the Number Range for Customer Contract or Customer Contract Template in the activity Number Ranges for Sales Orders, Customer Contracts, and Customer Returns in the Business Configuration work center.
Saving fails with the error message: Update for from number APCRM1_CONTRACT_IN failed; interval is already in use.
Environment
- SAP Business ByDesign
- SAP Cloud for Customer
Reproducing the Issue
- Go to Business Configuration work center.
- Click on Overview.
- Open the Activity: Number Ranges for Sales Orders, Customer Contracts, and Customer Returns.
- Mark for example Customer Contract and change the Begin Number.
- Click Save button.
- You get the error message: Update for from number APCRM1_CONTRACT_IN failed; interval is already in use.
Cause
The automatic Number Range from 0000000001 to 9999999999 is available by default.
The intended system behavior is:
- As long as no document has been created drawing a number from a given number range, in ByDesign it is possible to change the lower boundary of this interval (if it does not contradict with e.g. other ranges).
- As soon as the first number has been drawn from this number range, the lower boundary cannot be changed anymore. Then the error message "Update for from number... failed; interval is already in use." is returned and the change is prevented.
Resolution
This is the designed system behavior.
Keywords
numbering, 0000000001 to 9999999999, begin number, Betriebswirtschaftliche Konfiguration, Vertrag, Nummerierung, service, sales , KBA , AP-SLO-SO , Sales Order , AP-CCP-CC , Customer Contract , How To