Symptom
External candidates imported via 'Candidate Import' Legacy Data Migration job are not visible in Candidate Search.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Import candidate profiles during Legacy Data Migration using the prescribed process.
- Make sure all the job runs successfully and all the records are processed without error.
- Search for a candidate using Candidate Search.
- Candidate is not visible.
Cause
There are two main causes for this issue:
- Candidate Index - After importing the candidates using the legacy import, the candidates are not available in the search index by default.
- Data Consent Privacy Statement (DPCS) - If DPCS is enabled for external candidates and the following option is also enabled, the candidates will be visible in the instance only after they have accepted the Data Privacy statement.
- Manage Recruiting Settings > Allow Recruiting users to access candidate information if they have accepted one of the versions of the Data Privacy Consent Statement
Resolution
Here are the resolution for the two causes:
Candidate Index
There are two possible solutions.
a. The recruiter can manually open the candidate profile, this action will make the candidate available for the search.
b. In case many candidates have been imported, a reindex needs to be requested. Check this article to learn how to request it: 2230010 - How to Request an Instance Index/Re-index in Recruiting Management.
Data Consent Privacy Statement (DPCS)
The candidate will become visible after the DPCS is accepted, if the option "Allow Recruiting users to access candidate information if they have accepted one of the versions of the Data Privacy Consent Statement" is enabled.
During legacy data migration, there is no such field or flag that you can populate to manipulate the DPCS status. This status is determined only by a candidate manually accepting or rejecting the statement.
If a candidate has already accepted DPCS in the previous system before migrating to Successfactors, they will have to accept it again while logging into Successfactors external candidate account for the first time. There will be an automated prompt for acceptance of this statement and the candidate cannot bypass it. The candidate must accept the statement in order to proceed.
Additionally, there are two ways to accept DPCS on behalf of a candidate:
- Admin tool 'Set DPCS Statement Status' - KBA 2088053 - How to Accept Data Privacy Consent Statement (DPCS) on behalf of others - Recruiting Management
- OData API - KBA 3524394 - How to Update the Data Privacy Consent Statement via ODATA API - Recruiting Management
Note:
- When accepting DPCS on behalf of others, the administrator must make sure that they have the person's agreement.
- If the above option is not enabled, candidates will be visible if their profiles are properly indexed. However, disabling the option or not must comply with the Data Consent Privacy Statement. Please also note that enabling or disabling the feature will not take effect immediately.
See Also
Keywords
Data Privacy, Candidate Import, Legacy Data Migration, Candidate Search, instance index, reindex, External, Searchable, Appear , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , Problem