Symptom
Token [[CAREERSITE_USER_NAME]] is not resolving in "Welcome / Thanks for Creating Account".
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Recruiting Management (RCM)
Reproducing the Issue
1. Go to the "Recruiting Email Triggers".
2. Locate the trigger "Welcome / Thanks for Creating Account".
3. Associate the token [[CAREERSITE_USER_NAME]] with template associated with this trigger.
4. Create a new account on the career site.
5. After creating an account the above notification will be triggered to the candidate.
6. Check the email that candidate received and you will notice that [[CAREERSITE_USER_NAME]] did not get resolved.
Cause
The [[CAREERSITE_USER_NAME]] token is only supported in "Career Site E-Mail Notification" which is a totally different trigger present in "Recruiting Email Triggers".
Resolution
Replace the [[CAREERSITE_USER_NAME]] token with the [[CANDIDATE_FIRST_NAME]] and it will resolve the candidate name. The [[CAREERSITE_USER_NAME]] is only supported in "Career Site E-Mail Notification".
Keywords
Career Site E-Mail Notification Candidate name Welcome / Thanks for Creating Account notification , KBA , LOD-SF-RCM-EML , Recruiting Emails and Notifications , Problem