Symptom
A report background job will fail with a status of 'Aborted'
Problems: Please contact your administrator for more details on the error.
The error text will appear as a collection of ascii characters (like the example below). The actual characters will be different for each failure:
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Log into HCM >
- Navigate to Learning Administration > Reports >
- Select the required report, add the necessary filters, and schedule it to be executed as a background report job (by submitting the job through the 'Schedule Job' button) >
- Once the job gets completed, notice that it failed and the error displays a random collection of characters.
Cause
The error does not provide enough details on its own to identify root cause of the failure.
Resolution
In order to see more details on the error message, the following setting reportStackTraceToUser needs to be enabled:
- At Learning Administration > System Administration > Configuration > System Configuration >
- Open the LMS_ADMIN file in Edit mode >
- Search for reportStackTraceToUser > update it to reportStackTraceToUser=true > click on 'Apply Changes'.
Once the setting above is enabled, please run the report again by scheduling it. If it fails, the background job should display a more detailed error message.
Note:
- Background jobs can be consulted at Learning Administration > System Administration > Background Jobs;
- To search for the exact job, please add relevant filters (such as Date, Owner, Status, etc.).
Keywords
report job fail, aborted, Please contact your administrator, ascii characters, reportStackTraceToUser, reportStack, reportStackTrace, failure, report, stack, trace, log, error , KBA , LOD-SF-LMS-BCJ , Assign (bulk), Add/ Delete Sub/ Cur, Revise, Import , LOD-SF-LMS-REP , Reporting Data , Problem
SAP Knowledge Base Article - Public