Symptom
- Drop Down for field ‘Rule Type’ in ‘Configure Business rules’ is not displayed:
- Business Rule which were synced from one instance to another, show Application Error when trying to open rules:
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental
Environment
Employee Central
Reproducing the Issue
- Navigate to ‘Configure Business rules’. Select ‘Create New Rule’. The dropdown for the field ‘Rule Type’ is empty.
- Navigate to ‘Configure Business rules’. Search for a rule, you receive an application error with the text ‘An application error occurred. Please try again later, or notify support if the issue keeps occurring’.
Cause
The field ‘Rule Type’ makes queries on 'Effective Start Date: 01/01/1900'.
The Picklist assigned to this the field is ‘RuleType’.
This picklist must have an 'Effective Start Date: 01/01/1900'.
Resolution
Navigate to ‘Configure Object Definitions’. Search for the MDF picklist ‘RuleType’.
Make sure the picklist has effective ‘Effective Start Date: 01/01/1900’ if not change the effective start date.
See Also
2439274 - Application Error When Viewing a Business Rule
Keywords
Application Error, Business Rule, Rule Type, RuleType, Empty dropdown , KBA , LOD-SF-EC-FOO , Foundation Objects (Organisation, Pay and Job Structures) , Problem