SAP Knowledge Base Article - Public

2280042 - Reassign Activity to any User in the Work Queue - Onboarding 1.0

Symptom

  • Onboarding administrators want the ability to reassign an activity to anyone in the list of all users.
  • When trying to reassign an activity to a user, the system does not display any users.
  • The hiring manager is not able to reassign any activity to regular user in the Onboarding work queue or under Manage Employee.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors Onboarding 1.0

Reproducing the Issue

In Super Admin, when trying to utilize the "XpressHR.ManualReassgn" key from the account options area, the key is missing.

Cause

Missing configuration in super admin site.

Resolution

  1. If the key named "XpressHR.ManualReassign.AllowedUsers" is missing from Super Admin you can add this key.
  2. To add the key, you need to log into Super Admin.
  3. Once in Super Admin locate your account.
  4. Go to Account Options.
  5. Select " Add Option":

Add Account Option.png

  1. Enter the Name "ManualReassign.AllowedUsers" and select the value. Key and Group will automatically prepopulate:
  1. "Processes" Enter process name if you only want to use it for that process, or leave blank for all processes.
  2. Enter the Type "String".
  3. Enter the Value as " ALLUSERS".
  4. Note that this key by default has the value of "ASSIGNEDUSERS".

Keywords

SF, SuccessFactors, OBD, ONB, Onboarding, Reassign, Activity, ALLUSERS, ASSIGNEDUSERS, Key, Manual, Allowed, XpressHR , KBA , LOD-SF-OBD-ADM , Admin Tools, Settings, Permissions , Problem

Product

SAP SuccessFactors Onboarding all versions