Symptom
When a specific user navigates to the 'Careers' section to view internally posted jobs, the 'Internal Careers' tab does not display all available job requisitions. This issue is user-specific and occurs only when directly logging into the instance with the affected user's credentials.
Issue Description:
- The affected user is unable to see any internally posted jobs.
- The issue is isolated to the specific user; other users can see all job postings.
- Job postings are not visible when the affected user logs in directly to the instance.
- However, if another user proxies with the affected user's account, all job postings become visible.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Log in to the instance using the credentials of the affected user.
- Navigate to the "Careers" tab.
- Note that the "Careers" tab does not display any job postings.
- Proxy as the affected user.
- Navigate to the "Careers" tab again.
- Verify that all job postings are now visible.
Cause
Instance language has not been selected for the affected user profile.
Resolution
To ensure that all users can view jobs posted internally, it is crucial to select an instance language. By default, there is always a language selected, represented by a radio button. However, after a new employee file import, some employees may have an incorrect locale format, resulting in no language being selected.
To resolve the issue, ensure that a language is selected for the affected user.
Once the language is selected, affected candidate should be able to log in and see all internally posted jobs on the career site.
Keywords
Internal, job, career, portal, site, language , KBA , LOD-SF-RCM , Recruiting Management , Problem