Symptom
When a user navigates to Careers to see jobs posted internally, the internal careers tab isn't showing all available job requisitions
Environment
SuccessFactors BizX - Recruiting Management(RCM)
Reproducing the Issue
Issue Description: None of the internally posted jobs available to one specific user. Jobs are not showing on the internal career site only when you directly login to the instance with the affected user. However, if some other user proxy with the affected user, they can see all jobs posted
1) Login to instance with affected user and navigate to Careens tab. It will not show any jobs posted.
2) Proxy with the affected user and you can see all jobs.
3) Reason for this issue is instance language not selected for the affected candidate
4) Select a language to resolve this issue
5) You will see that when affected candidate directly logged in to the system, career site will show all jobs posted internally.
6) Instance language must be selected for all users to see jobs posted internally. As there is a radio button on the language, there will be always any language selected already. However, in some condition where you have done a new employee file import, some employees had wrong format of the locale selected which resulted in having nothing selected in the language.
Cause
No instance language selected for the affected user.
Resolution
Select an instance language
Keywords
Internal jobs , KBA , LOD-SF-RCM , Recruiting Management , Problem