Symptom
Whenever the item is created in LMS admin, their default value for "Approval Required" field is set to No. Customers may want to be able to change this default value for new records creation.
Environment
-SuccessFactors Learning Management System
Reproducing the Issue
- Login to LMS ADMIN
- Navigate to Learning Activities> Items> click Add New
- The "Approval Required" set as No by default
Cause
There is currently no setting to change this default value in the LMS
Resolution
The default value of this filed (and other fields) when creating a new item record cannot currently be changed in the LMS.
Should customers wish to have a feature allowing them to change this default value in the system, we advise submitting an enhancement request. Please see details here https://launchpad.support.sap.com/#/notes/0002090228
Additionnal notes:
- When adding items manually we cannot mark the default approval required to Yes, however we can set the default Approval in LMS Admin> Configuration> Global variables> Default Internal Approval Process ID
- When mass importing the items via the item connector, you can use these two headers to choose the settings for the "approval required" and "withdraw approval required" fields: WITHDRAW_APPROVAL_REQD and APPROVAL_REQD
Keywords
approval required, default value,create item, , KBA , LOD-SF-LMS-ITE , Items , LOD-SF-LMS-ADM , System Admin, Global Variables, References , Product Enhancement