Symptom
- Pre-Day Hire1 Email is not generating for candidates.
Environment
- Applicable for all DC centres and KMS(Zerolag) Customers.
- Onboarding
- Provisioning
Cause
- Pre-day hire1 option is not enabled in provisioning.
- Email Template notifications is disabled.
Resolution
1.Enable Pre-day Hire1 option is enabled in provisioning.
2.Enable Reset password email in (Admin center--email template Notifications).
3.Check for candidate in audit Trail for event code (SF_INTEGRATION=500 Internal error or 403 Forbidden Error)
If error occured means below one of the notification has been failed:
a)Candidate Create Notification.
b)Post PHV Notification.
c)PaperWorkDone Notification.
If above mentioned Post PHV notification or Candidate Create Notification has failed,then the user id will not get generated in BIZX side so that pre-day hire1 email will not generate for the candidate.
In data dictionary--fields in post phv tags ,once the candidate created in onboarding these required fields will get communicated to bizx and user id will be generated so that the pre-day hire1 email will generate to candidate.Please make ensure that in admin data--Manage users--Required fields for users should have an value from onboarding.If required field is not present ,then post phv notification failed and user id will not created,pre-day hire1 email will not get generated to candidate.
4.Check the user sync between Bizx and ONB.
5.User id in OCI should be present ,if not email will not generate for candidate.
6.In Provisioning--single reciepent value should be empty.
7.In Integrations,in all 3 tags(Hiring manager,hramanager,WOTCstartdate,firstname,lastname should be present)
Keywords
- Pre-day hire1 welcome email not generating
- Pre-day hire1