Symptom
- No emails received from LMS (system notifications and ad hoc notifications).
- Emails are stuck in PA_MAIL.
Environment
Learning Management System (LMS)
Reproducing the Issue
- Run any APM (Automatic Process Mangement) and wait to receive messages.
- Send any ad-hoc notification and wait to receive messages.
- No messages are received.
Cause
The issue was caused by apmLearningExpiration because the message body and subject of the notification template apmTrainingExpiration had been deleted and all messages triggered by this apm caused an error. This error caused all other messages to be stuck in PA_MAIL database table.
Resolution
- Disable the Learning Expiration APM
- Paste message body and subject to apmTrainingExpiration notification template
- Enable the APM again
NOTE: If the "Cause" and "Resolution" section are not applicable / have been performed but issue still persists, reach out to Cloud Support. Operations Team would be engaged to check if there's something on the backend that's causing the emails from being sent out of SF SMTP Servers.
See Also
2473912 - Troubleshooting Email Notification - Guided Answer
Keywords
Emails stuck in PA_MAIL table, notification template has empty message body and subject , KBA , LOD-SF-LMS-NOT , Notifications , LOD-SF-LMS , Learning Management System , Problem