SAP Knowledge Base Article - Public

2287959 - Person ID External already exists

Symptom

When creating a new Employee via import, after importing the Basic User Data you encounter an error message [There is already another person in the system with the same Person ID External] when validating/importing Biographical Information for a user.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

 PersonID_in_use.JPG

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

An orphaned Person ID External can be created in 2 ways -:

Data Retention Management - User Purge -  Prior to b1511 release - when using the Data Retention Management (DRM) tool to Purge Inactive Users - it was possible to select the option "Purge Inactive User (EC Data Only)" which allowed the deletion of EC data. Performing this particular Purge action caused the Person ID to become orphaned and key EC data to be deleted. This was because the tool was not being used as designed. In b1511 a change to the DRM was introduced to prevent the execution of this option separately from a Purge Inactive User job. Now as of b1511 - the DRM will remove EC data at the same time the User is being purged. However, customers with EC enabled who purged users prior to b1511 release, where they require to re-use the UserID, this issue could still be encountered. This is classed as a Data Issue. For more information on the DRM tool, please refer to KBA 2088065 to better understand the process and current limitations

OR

Biographical Information creation via Import/API - The orphaned Person ID was created via Biographical Information import/upsert. This is accepted by the system because this is how you create Dependents in Employee Central. Please refer to KBA 2186440 for more details on creating Dependents via Import/API. This can also mean, if you create a New Hire via Imports/API, and you perform the data loads in the wrong order, potentially you can create the Person ID External so it is treated as a Dependent instead of being linked to a User ID.

Cause

The issue here could be that the Person ID for your employee was created via Biographical Information import before the Basic User Data was created. This is possible as mentioned above, you can create a Person ID via import that is not associated with a User ID, as this is how Dependents are created. This can happen when the Employee was created via import but the data import was performed in the wrong order (should always be Basic User Data > Biographical Information > Employment Details > Job Info > Personal Info > other data - when creating a New Hire in Employee Central). Same order applies when creating users via API.

  • For more information regarding the correct order to import/upsert data when creating new Employee's via import can be found in the Employee Central Master handbook found here. Refer to section titled "Importing Employee Data".

The other possibility is that the user was purged prior to b1511 release, and potentially have a data issue, where the Person ID is orphaned and can no longer be used/associated with an Employee

Resolution

Please follow the guidance provided in this article, to easily identify and delete orphaned Person ID's.

 

 

 

Identifying an orphaned Person ID via the UI

Please be diligent and perform all below recommended checks before proceeding, as a Person ID that is already in use can indicate that a Dependent exists in the system with the suspected orphaned Person ID, or event the simple fact that the Person ID is already assigned to another User ID. You can however follow these next steps to determine whether a Person ID exists in the system that does not have a User ID associated with it.

 

How to use Check Tool to check if there are any Orphan Person ID Externals in the system.

It is now quite simple to identify if you have any orphaned Person ID's in your instance using the Check Tool feature. Please follow this article which explains how to run the check and export the list of orphaned ID's.

  • 2438812 - Check Tool: How to use Check Tool to check if there are any Orphan Person ID Externals in the system.

 

How to delete an orphaned Person ID

This issue can now be solved from the Admin Center UI, and does not require engaging with Product Support or running any correctives Database scripts.

It is now possible to leverage the "Composite Delete" feature for Import Employee Data to delete all the data from specific EC tables in the database. This includes personInfo table (which stores Person ID).

Please follow the guidance provided in 2438812 - Check Tool: How to use Check Tool to check if there are any Orphan Person ID Externals in the system.

 

Some alternatives to running the Check Tool to identify orphaned Person ID are (but we recommend using the Check Tool as its super simple)

Since the Check Tool will perform the below actions in 1 click, the following 2 examples are not required anymore BUT we include them here still as alternative methods are always helpful.

 

1) Checking if Person ID is alreasdy assigned to a UserID via Ad Hoc Reporting

  1. Navigate to Analytics > Reporting > Create new Ad Hoc report and select the schema "Person and Employment Export"
  2. Give the report a sensible name such as "Employee Person ID Check"
  3. Under "Columns" select "All Columns" and then select the Column "User/Employee ID" (which is the UserID column).
  4. Then under Column Set select "Person Info" and then select all columns under Person Info
  5. Click Finished and then click Save. Once save is complete, click Generate.

Export the report and open in Excel and check to see whether the Person ID in question is included in the report. If the Person ID is included in the report, it indicates that it is already assigned to a UserID. If the Person ID is not listed in this report then it could indicate that either it is being used by a Dependent OR it has been orphaned.

 

2) Checking if Person ID is alreasdy assigned to a Dependent via Advanced Reporting (ORD)

As mentioned in KBA 2280959 it is not possible to report on Dependents data via Ad Hoc Reporting. Instead you must use Advanced Reporting to report on Dependents Data. The report is typically labelled "Dependents".

Use the Dependents Advanced Report to be able to report on all Dependents in the system. Export the report output to Excel so you can check to see whether a Dependent exists with the related Person ID

See Also

  • 2438812 - Check Tool: How to use Check Tool to check if there are any Orphan Person ID Externals in the system.

Keywords

ECT-27017, ECT-48158, ECT-48704, There is already another person in the system with the same Person ID External, Import, Biographical Info, PerPerson, Person Info, Purge, Script, CORE_JI_CHECK_03, Orphan Person ID Externals in the system , KBA , LOD-SF-EC-PER , Person Data (All Person Data Types) , LOD-SF-EC , Employee Central , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions