SAP Knowledge Base Article - Public

2289530 - Application Error on Viewing Synced Rule.

Symptom

After sync a rule from another instance, you receive an application error when viewing the rule.
2.png

Environment

Employee Central

Reproducing the Issue

Sync a business rule from another instance.

When trying to view the rule via >Configure Business Rules, you receive an application error.

Cause

One possible cause is as follows.

If the rule contains a message definition, then the rule will try to look for the message definition in the instance.
If the message definition does not exist you will receive an error when trying to view the rule.

Resolution

To resolve this issue sync the message definitions along with the rules to the instance.

See Also

2279954

Keywords

KBA , synchronization , application error , business rule , rule , LOD-SF-EC , Employee Central , LOD-SF-EC-RUL , DO NOT USE - Business Rules & Event Derivation , Problem

Product

SAP SuccessFactors Employee Central all versions