Symptom
The following error is seen (would be specific with the actual field name for each case as seen in the screenshot below) from the Execution Manager of Integration Center
Maximum Length exceeded <field> for record seqNumber:
Environment
SuccessFactors BizX
Reproducing the Issue
- Run the Process in Integration Center.
- No errors are seen, however, there are a lot of warning with the above error message in the Execution Manager [Integration Center].
- Final output file doesn't contain expected data for the errored records.
Cause
The "Maximum Number of Characters" for that particular field has exceeded the defined value in the Field Configuration on the Integration Center UI.
Resolution
Two ways of going about the issue here:
1. Reduce the number of characters for the value that is being passed for that particular field (requires data modification on BizX)
2. Increase the limit on this field.
Increase the limit:
- Go to Integration Center.
- For Export process, select the Process and go to the "Configure Fields" tab.
- Scroll Horizontally until you find the field column that is of interest (here "Department Description")
- Right click on the field as seen below and click on "More Field Options"
- Increase the limit of the characters here by the required value.
- For Import process, select the Process and go to the "Configure Fields" tab, click on button "Switch to File Import Test View"
- Scroll Horizontally until you find the field column that is of interest
- Right click on the field as seen below and click on "More Field Options"
- Increase the limit of the characters here by the required value.
Keywords
KBA , LOD-SF-INT , Integrations , Problem