Symptom
Custom text formatting applied via WYSIWYG notification template editor, is not applied to syntax tag data or part of the notification body..
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Edit a notification template to use various font types, colors, and/or format.
- Trigger notification.
- Notice that syntax tag data or part of the notification is displayed in plain text.
Cause
Formatting wasn't applied to syntax tags or part of the body when configuring the notification template.
Resolution
To apply formatting to syntax tags which populate data in notifications (i.e. List of User IDs, Schedule Description, Segment Grid, etc):
-
Add the syntax tags or text to be used in the notification (or use the default syntax tags already applied to the notification template).
- Select the syntax tag or text to be formatted (make sure that the text is highlighted).
-
Apply the formatting manually (font, style, size).
- Click Save.
This process is similar to formatting text in a word processing application such as MS Word.
Keywords
syntax-tag, syntax tag-driven data, configure, customizations, email, plain text, kal, kac, new editor, font, color, notifications, item, scheduled offering, learning plan, cancellation, registration, user request, SO, S.O., text font, font style, font size , KBA , LOD-SF-LMS-NOT , Notifications , Problem