SAP Knowledge Base Article - Public

2290928 - LMS: Users don't receive notifications for recommended items

Symptom

When learning users recommend an item to others, notifications are not being triggered.

Environment

SuccessFactors Learning Management System (LMS) - All Supported Versions since b1602

Reproducing the Issue

  1. Recommend a learning item via catalog or learning plan to another user.  
  2. The user should receive a notification for the recommended item.

Cause

The Recommendations Newsletter APM is not scheduled.

Resolution

The Recommendations Newsletter Automatic Process Manager (APM) sends recommendations to users.

The Recommendations Newsletter Automatic Process Manager (APM) sends the recommendations that the system has found for a user. It does not make the recommendations. Recommendations can come from multiple sources, such as a peer or from the recommendations engine.

If you are using the personalized recommendations engine (in preview release), the system sends out a newsletter to users with a set of recommended courses. These courses are gathered from beyond your organization, including social media. Customers who have signed up for the preview program can use the recommendations engine.

The recommendations engine can be configured via System Admin > Configuration > System Comfiguration > Personalized Recommendations

Keywords

recommended, recomend, course, class, automatic process, email, not sent, kal, kac, Recommendations Newsletter Automatic Process Manager , KBA , LOD-SF-LMS-NOT , Notifications , Problem

Product

SAP SuccessFactors Learning all versions